trying to get started on ubuntu 16.04.5 LTS and struggling


kisiel
3 months ago (Edited 3 months ago) 0 kisiel 1

Following the documentation, I run:

# echo "deb http://packages.lizardfs.com/ubuntu/$(lsb_release -sc) $(lsb_release -sc) main" > /etc/apt/sources.list.d/lizardfs.list

# echo "deb-src http://packages.lizardfs.com/ubuntu$(lsb_release -sc) $(lsb_release -sc) main" >> /etc/apt/sources.list.d/lizardfs.list


but got massive update erros. I assume that the second line sis missing one "/" and should read

# echo "deb-src http://packages.lizardfs.com/ubuntu/$(lsb_release -sc) $(lsb_release -sc) main" >> /etc/apt/sources.list.d/lizardfs.list


could someone confirm it?


However, I am still getting:

N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://packages.lizardfs.com/ubuntu/xenial xenial InRelease' doesn't support architecture 'i386'


is this normal or do I do something wrong?



Then I tried to go with the compilation from source, but I failed to find a list of dependencies.

It first failed on "cmake" and "unzip" and later on "FUSE" libraries.

Where can I find what is supposed to be installed before compilation?


Thanks,

Marcin



I finally used pre-compiled binaries.

Shame, however, that this forum seems to be dead.


Reading this thread: